Meshy for Godot

Installez le plug-in Meshy dans l'éditeur Godot afin de pouvoir envoyer des modèles depuis l'application web Meshy directement dans vos scènes Godot.


Avant de commencer

  • Téléchargez le plug-in, un fichier .zip, depuis la page d'intégration Meshy for Godot.

  • Vous avez besoin d'un compte Meshy. Pour envoyer des modèles avec le Bridge, vous avez besoin d'un forfait Pro ou supérieur.

Installer le plug-in

Pour installer le plug-in, suivez ces étapes :

  1. Décompressez le fichier que vous avez téléchargé. Il contient un dossier meshy-godot-plugin.

  2. Si votre projet ne possède pas de dossier addons, dans le panneau FileSystem de Godot, faites un clic droit sur res://, puis cliquez sur Create New > Folder.

    Panneau FileSystem de Godot avec le menu contextuel de res:// ouvert et Create New, Folder mis en évidence

  3. Saisissez addons comme nom de dossier.

  4. Cliquez sur OK.

    Boîte de dialogue Create Folder de Godot avec addons saisi comme nom et le bouton OK

    Panneau FileSystem de Godot affichant le nouveau dossier addons sous res://
  5. Faites glisser le dossier meshy-godot-plugin dans le dossier addons dans le panneau FileSystem. Conservez le nom du dossier tel quel, car le plug-in charge ses fichiers depuis res://addons/meshy-godot-plugin.

    Panneau FileSystem de Godot avec le dossier meshy-godot-plugin et ses fichiers à l'intérieur de addons

  6. Dans la barre de menu de Godot, cliquez sur Project > Project Settings, puis cliquez sur l'onglet Plugins.

  7. Cochez la case Enabled pour Meshy official plugin.

    Project Settings de Godot sur l'onglet Plugins avec Meshy official plugin répertorié et activé

Lorsque le plug-in est activé, un onglet Meshy apparaît en haut de l'éditeur, à côté de AssetLib. Il ouvre le panneau que vous utilisez pour recevoir des modèles.

Onglets de l'éditeur Godot 2D, 3D, Script, Game, AssetLib, et l'onglet Meshy ajouté par le plug-in

Étapes suivantes

  • Pour envoyer votre premier modèle de Meshy vers Godot, consultez Bridge to Godot.

  • Pour importer un personnage riggé avec son animation, consultez Modèles animés.