Meshy für Godot

Installieren Sie das Meshy-Plugin im Godot-Editor, damit Sie Modelle direkt aus der Meshy-Web-App in Ihre Godot-Szenen senden können.


Bevor Sie beginnen

  • Laden Sie das Plugin, eine .zip-Datei, von der Meshy für Godot-Integrationsseite herunter.

  • Sie benötigen ein Meshy-Konto. Um Modelle mit der Bridge zu senden, benötigen Sie einen Pro-Plan oder höher.

Plugin installieren

Gehen Sie wie folgt vor, um das Plugin zu installieren:

  1. Entpacken Sie die heruntergeladene Datei. Sie enthält einen Ordner namens meshy-godot-plugin.

  2. Wenn Ihr Projekt keinen addons-Ordner hat, klicken Sie im Godot-FileSystem-Dock mit der rechten Maustaste auf res:// und dann auf Create New > Folder.

    Godot-FileSystem-Dock mit geöffnetem res://-Kontextmenü und hervorgehobenem Create New, Folder

  3. Geben Sie addons als Ordnernamen ein.

  4. Klicken Sie auf OK.

    Godot-Create-Folder-Dialog mit addons als eingegebenem Namen und der OK-Schaltfläche

    Godot-FileSystem-Dock mit dem neuen addons-Ordner unter res://
  5. Ziehen Sie den Ordner meshy-godot-plugin in den addons-Ordner im FileSystem-Dock. Behalten Sie den Ordnernamen unverändert bei, da das Plugin seine Dateien aus res://addons/meshy-godot-plugin lädt.

    Godot-FileSystem-Dock mit dem Ordner meshy-godot-plugin und seinen Dateien innerhalb von addons

  6. Klicken Sie in der Godot-Menüleiste auf Project > Project Settings und dann auf die Registerkarte Plugins.

  7. Aktivieren Sie das Kontrollkästchen Enabled bei Meshy official plugin.

    Godot Project Settings auf der Registerkarte Plugins mit aufgelistetem und aktiviertem Meshy official plugin

Wenn das Plugin aktiviert ist, erscheint oben im Editor neben AssetLib eine Registerkarte Meshy. Sie öffnet das Panel, über das Sie Modelle empfangen.

Godot-Editor-Registerkarten 2D, 3D, Script, Game, AssetLib und die vom Plugin hinzugefügte Meshy-Registerkarte

Nächste Schritte

  • Informationen zum Senden Ihres ersten Modells von Meshy nach Godot finden Sie unter Bridge to Godot.

  • Informationen zum Importieren eines geriggten Charakters mit seiner Animation finden Sie unter Animierte Modelle.