Meshy for Godot

Godot 에디터에 Meshy 플러그인을 설치하여 Meshy 웹 앱에서 Godot 씬으로 모델을 바로 전송할 수 있습니다.


시작하기 전에

  • Meshy for Godot 통합 페이지에서 .zip 파일 형태의 플러그인을 다운로드하세요.

  • Meshy 계정이 필요합니다. Bridge로 모델을 전송하려면 Pro 플랜 이상이 필요합니다.

플러그인 설치

플러그인을 설치하려면 다음 단계를 따르세요:

  1. 다운로드한 파일의 압축을 풉니다. 여기에는 meshy-godot-plugin 폴더가 포함되어 있습니다.

  2. 프로젝트에 addons 폴더가 없다면, Godot FileSystem 독에서 res://를 마우스 오른쪽 버튼으로 클릭한 다음 Create New > Folder를 클릭합니다.

    Godot FileSystem dock with the res:// context menu open and Create New, Folder highlighted

  3. 폴더 이름으로 addons를 입력합니다.

  4. OK를 클릭합니다.

    Godot Create Folder dialog with addons entered as the name and the OK button

    Godot FileSystem dock showing the new addons folder under res://
  5. meshy-godot-plugin 폴더를 FileSystem 독의 addons 폴더 안으로 드래그합니다. 플러그인은 res://addons/meshy-godot-plugin에서 파일을 불러오므로 폴더 이름은 그대로 유지하세요.

    Godot FileSystem dock with the meshy-godot-plugin folder and its files inside addons

  6. Godot 메뉴 바에서 Project > Project Settings를 클릭한 다음 Plugins 탭을 클릭합니다.

  7. Meshy official plugin의 Enabled 체크박스를 선택합니다.

    Godot Project Settings on the Plugins tab with Meshy official plugin listed and enabled

플러그인이 활성화되면 에디터 상단, AssetLib 옆에 Meshy 탭이 나타납니다. 이 탭을 클릭하면 모델을 수신하는 데 사용하는 패널이 열립니다.

Godot editor tabs 2D, 3D, Script, Game, AssetLib, and the Meshy tab added by the plugin

다음 단계

  • Meshy에서 Godot으로 첫 모델을 전송하려면 Bridge to Godot 문서를 참고하세요.

  • 애니메이션이 포함된 리깅된 캐릭터를 가져오려면 애니메이션 모델 문서를 참고하세요.