Meshy for Unreal

Unreal Engine に Meshy プラグインをインストールすると、Meshy ウェブアプリからモデルを Unreal Editor で開いているレベルに直接送信できます。


はじめに

  • Meshy for Unreal Engine integration page からプラグインをダウンロードします。プラグインはエンジンのバージョンごとに別々のビルドが用意されています。詳細は以下の通りです。

    • Windows では、お使いのエンジンバージョン用のビルド(UE 5.4、5.5、5.6、または 5.7)をダウンロードしてください。各ビルドは、そのために作られたエンジンバージョンでのみ動作します。

    • macOS の場合、または専用ビルドが存在しないエンジンバージョンの場合は、ソースパッケージをダウンロードしてください。これにはプラグインのソースコードが含まれており、ご自身でコンパイルする必要があります。macOS では、プラグインには UE 5.5 以降が必要です。

  • Meshy アカウントが必要です。ブリッジでモデルを送信するには、Pro プラン以上が必要です。

プラグインのインストール

プラグインは、エンジンにインストールしてすべてのプロジェクトで使用することも、単一のプロジェクトにインストールすることもできます。

プラグインをインストールするには、以下の手順に従ってください。

  1. ダウンロードしたファイルを、以下のいずれかのフォルダに解凍します。

    • すべてのプロジェクトで使用する場合: エンジンの Engine/Plugins フォルダ。例えば Windows では C:\Program Files\Epic Games\UE_5.x\Engine\Plugins、macOS では /Users/Shared/Epic Games/UE_5.x/Engine/Plugins です。

    • 1 つのプロジェクトで使用する場合: プロジェクトフォルダ内の Plugins フォルダ。フォルダが存在しない場合は作成してください。

    ファイルには meshy フォルダが含まれているため、プラグインは Plugins/meshy に配置されることになります。

  2. Unreal Editor でプロジェクトを開きます。

  3. Edit > Plugins をクリックし、meshy が有効になっていることを確認します。

  4. 前のステップでプラグインを有効にした場合は、エディターを再起動します。

プラグインが読み込まれると、Window メニューに Meshy Bridge の項目が表示されます。これを使用して、Meshy からモデルを受信するブリッジを開始・停止します。

Unreal Editor Window menu open, with an arrow pointing to the Meshy Bridge item and its empty checkbox

次のステップ

  • Meshy から Unreal へ初めてモデルを送信する方法については、Bridge to Unreal Engine を参照してください。

  • リギングされたキャラクターをそのアニメーションとともにインポートする方法については、Animated models を参照してください。