Meshy for Godot

Godot エディターに Meshy プラグインをインストールすると、Meshy ウェブアプリからモデルを直接 Godot のシーンに送信できるようになります。


はじめに

  • Meshy for Godot integration page から、.zip ファイルであるプラグインをダウンロードしてください。

  • Meshy アカウントが必要です。ブリッジでモデルを送信するには、Pro プラン以上が必要です。

プラグインのインストール

プラグインをインストールするには、次の手順に従ってください。

  1. ダウンロードしたファイルを解凍します。中には meshy-godot-plugin フォルダーが含まれています。

  2. プロジェクトに addons フォルダーがない場合は、Godot の FileSystem ドックで res:// を右クリックし、Create New > Folder をクリックします。

    res:// のコンテキストメニューが開き、Create New、Folder がハイライトされた Godot FileSystem ドック

  3. フォルダー名として addons と入力します。

  4. OK をクリックします。

    名前として addons が入力された Godot の Create Folder ダイアログと OK ボタン

    res:// の下に新しい addons フォルダーが表示された Godot FileSystem ドック
  5. meshy-godot-plugin フォルダーを FileSystem ドック内の addons フォルダーにドラッグします。プラグインは res://addons/meshy-godot-plugin からファイルを読み込むため、フォルダー名はそのままにしてください。

    addons の中に meshy-godot-plugin フォルダーとそのファイルが入った Godot FileSystem ドック

  6. Godot のメニューバーで Project > Project Settings をクリックし、次に Plugins タブをクリックします。

  7. Meshy official plugin の Enabled チェックボックスを選択します。

    Plugins タブに Meshy official plugin が表示され、有効化された Godot Project Settings

プラグインが有効になると、エディターの上部、AssetLib の隣に Meshy タブが表示されます。このタブから、モデルを受け取るためのパネルを開くことができます。

2D、3D、Script、Game、AssetLib、そしてプラグインによって追加された Meshy タブが表示された Godot エディターのタブ

次のステップ

  • Meshy から Godot へ最初のモデルを送信する方法については、Bridge to Godot を参照してください。

  • アニメーション付きでリギングされたキャラクターをインポートする方法については、アニメーション付きモデル を参照してください。