Meshy for Godot

Nainstalujte plugin Meshy v editoru Godot, abyste mohli posílat modely z webové aplikace Meshy přímo do svých scén v Godot.


Než začnete

  • Stáhněte si plugin, soubor .zip, ze stránky integrace Meshy for Godot.

  • Potřebujete účet Meshy. Pro odesílání modelů pomocí Bridge potřebujete plán Pro nebo vyšší.

Instalace pluginu

Při instalaci pluginu postupujte podle těchto kroků:

  1. Rozbalte stažený soubor. Obsahuje složku meshy-godot-plugin.

  2. Pokud váš projekt nemá složku addons, v panelu FileSystem v Godot klikněte pravým tlačítkem na res:// a poté klikněte na Create New > Folder.

    Panel FileSystem v Godot s otevřenou kontextovou nabídkou res:// a zvýrazněnými položkami Create New, Folder

  3. Jako název složky zadejte addons.

  4. Klikněte na OK.

    Dialog Create Folder v Godot se zadaným názvem addons a tlačítkem OK

    Panel FileSystem v Godot zobrazující novou složku addons pod res://
  5. Přetáhněte složku meshy-godot-plugin do složky addons v panelu FileSystem. Ponechte název složky beze změny, protože plugin načítá své soubory z res://addons/meshy-godot-plugin.

    Panel FileSystem v Godot se složkou meshy-godot-plugin a jejími soubory uvnitř addons

  6. V nabídce Godot klikněte na Project > Project Settings a poté klikněte na kartu Plugins.

  7. Zaškrtněte políčko Enabled u položky Meshy official plugin.

    Nastavení projektu Godot na kartě Plugins s uvedeným a povoleným pluginem Meshy official plugin

Jakmile je plugin povolen, v horní části editoru se vedle AssetLib zobrazí karta Meshy. Otevírá panel, který slouží k přijímání modelů.

Karty editoru Godot 2D, 3D, Script, Game, AssetLib a karta Meshy přidaná pluginem

Další kroky

  • Chcete-li poslat svůj první model z Meshy do Godot, přečtěte si Bridge to Godot.

  • Chcete-li importovat riggovanou postavu s její animací, přečtěte si Animované modely.