Meshy for Godot

Установите плагин Meshy в редакторе Godot, чтобы отправлять модели из веб-приложения Meshy прямо в ваши сцены Godot.


Прежде чем начать

  • Скачайте плагин, файл .zip, со страницы интеграции Meshy for Godot.

  • Вам понадобится аккаунт Meshy. Чтобы отправлять модели с помощью Bridge, вам нужен план Pro или выше.

Установка плагина

Чтобы установить плагин, выполните следующие шаги:

  1. Распакуйте скачанный файл. Он содержит папку meshy-godot-plugin.

  2. Если в вашем проекте нет папки addons, в доке FileSystem редактора Godot щёлкните правой кнопкой мыши по res://, а затем нажмите Create New > Folder.

    Док FileSystem в Godot с открытым контекстным меню res:// и выделенными пунктами Create New, Folder

  3. Введите addons в качестве имени папки.

  4. Нажмите OK.

    Диалоговое окно Create Folder в Godot с введённым именем addons и кнопкой OK

    Док FileSystem в Godot с новой папкой addons под res://
  5. Перетащите папку meshy-godot-plugin в папку addons в доке FileSystem. Оставьте имя папки без изменений, так как плагин загружает свои файлы из res://addons/meshy-godot-plugin.

    Док FileSystem в Godot с папкой meshy-godot-plugin и её файлами внутри addons

  6. В строке меню Godot нажмите Project > Project Settings, а затем откройте вкладку Plugins.

  7. Установите флажок Enabled для Meshy official plugin.

    Настройки проекта Godot на вкладке Plugins со списком Meshy official plugin и включённым флажком

Когда плагин включён, в верхней части редактора появляется вкладка Meshy, рядом с AssetLib. Она открывает панель, которую вы используете для получения моделей.

Вкладки редактора Godot 2D, 3D, Script, Game, AssetLib и добавленная плагином вкладка Meshy

Дальнейшие шаги