Meshy for Godot

Installeer de Meshy-plug-in in de Godot-editor, zodat je modellen rechtstreeks vanuit de Meshy web-app naar je Godot-scènes kunt sturen.


Voordat je begint

  • Download de plug-in, een .zip-bestand, van de Meshy for Godot-integratiepagina.

  • Je hebt een Meshy-account nodig. Om modellen met de Bridge te versturen, heb je een Pro-abonnement of hoger nodig.

De plug-in installeren

Volg deze stappen om de plug-in te installeren:

  1. Pak het gedownloade bestand uit. Het bevat een map meshy-godot-plugin.

  2. Als je project geen map addons heeft, klik dan in het FileSystem-paneel van Godot met de rechtermuisknop op res:// en klik vervolgens op Create New > Folder.

    Godot FileSystem-paneel met het contextmenu van res:// geopend en Create New, Folder gemarkeerd

  3. Voer addons in als mapnaam.

  4. Klik op OK.

    Godot Create Folder-dialoogvenster met addons ingevoerd als naam en de OK-knop

    Godot FileSystem-paneel met de nieuwe map addons onder res://
  5. Sleep de map meshy-godot-plugin naar de map addons in het FileSystem-paneel. Houd de mapnaam ongewijzigd, omdat de plug-in zijn bestanden laadt vanaf res://addons/meshy-godot-plugin.

    Godot FileSystem-paneel met de map meshy-godot-plugin en de bijbehorende bestanden binnen addons

  6. Klik in de menubalk van Godot op Project > Project Settings en klik vervolgens op het tabblad Plugins.

  7. Schakel het selectievakje Enabled in bij Meshy official plugin.

    Godot Project Settings op het tabblad Plugins met Meshy official plugin vermeld en ingeschakeld

Zodra de plug-in is ingeschakeld, verschijnt er een tabblad Meshy bovenaan de editor, naast AssetLib. Dit opent het paneel dat je gebruikt om modellen te ontvangen.

Godot-editortabbladen 2D, 3D, Script, Game, AssetLib en het door de plug-in toegevoegde Meshy-tabblad

Volgende stappen