Meshy for Godot

ติดตั้งปลั๊กอิน Meshy ในเอดิเตอร์ Godot เพื่อให้คุณสามารถส่งโมเดลจากเว็บแอป Meshy เข้าสู่ฉากใน Godot ของคุณได้โดยตรง


ก่อนเริ่มต้น

  • ดาวน์โหลดปลั๊กอิน ซึ่งเป็นไฟล์ .zip จากหน้าการผสานรวม Meshy for Godot

  • คุณต้องมีบัญชี Meshy หากต้องการส่งโมเดลผ่าน bridge คุณต้องมีแพ็กเกจ Pro ขึ้นไป

ติดตั้งปลั๊กอิน

หากต้องการติดตั้งปลั๊กอิน ให้ทำตามขั้นตอนต่อไปนี้

  1. แตกไฟล์ที่คุณดาวน์โหลดมา ภายในจะมีโฟลเดอร์ meshy-godot-plugin

  2. หากโปรเจกต์ของคุณไม่มีโฟลเดอร์ addons ให้ไปที่แถบ FileSystem ของ Godot คลิกขวาที่ res:// จากนั้นคลิก Create New > Folder

    แถบ FileSystem ของ Godot ที่เปิดเมนูบริบทของ res:// พร้อมไฮไลต์ Create New, Folder

  3. ป้อน addons เป็นชื่อโฟลเดอร์

  4. คลิก OK

    กล่องโต้ตอบ Create Folder ของ Godot ที่ป้อนชื่อ addons พร้อมปุ่ม OK

    แถบ FileSystem ของ Godot ที่แสดงโฟลเดอร์ addons ใหม่ภายใต้ res://
  5. ลากโฟลเดอร์ meshy-godot-plugin ไปไว้ในโฟลเดอร์ addons ในแถบ FileSystem โดยคงชื่อโฟลเดอร์ไว้ตามเดิม เนื่องจากปลั๊กอินจะโหลดไฟล์จาก res://addons/meshy-godot-plugin

    แถบ FileSystem ของ Godot ที่แสดงโฟลเดอร์ meshy-godot-plugin และไฟล์ต่าง ๆ ภายในโฟลเดอร์ addons

  6. ในแถบเมนูของ Godot คลิก Project > Project Settings จากนั้นคลิกแท็บ Plugins

  7. เลือกช่องกาเครื่องหมาย Enabled สำหรับ Meshy official plugin

    หน้า Project Settings ของ Godot ในแท็บ Plugins ที่แสดง Meshy official plugin และเปิดใช้งานอยู่

เมื่อเปิดใช้งานปลั๊กอินแล้ว แท็บ Meshy จะปรากฏขึ้นที่ด้านบนของเอดิเตอร์ ถัดจาก AssetLib โดยแท็บนี้จะเปิดแผงที่คุณใช้สำหรับรับโมเดล

แท็บของเอดิเตอร์ Godot ได้แก่ 2D, 3D, Script, Game, AssetLib และแท็บ Meshy ที่เพิ่มโดยปลั๊กอิน

ขั้นตอนถัดไป

  • หากต้องการส่งโมเดลแรกของคุณจาก Meshy ไปยัง Godot ดู Bridge to Godot

  • หากต้องการนำเข้าตัวละครที่มี rig พร้อมแอนิเมชัน ดู โมเดลแอนิเมชัน