Meshy for Godot

Cài đặt plugin Meshy trong trình chỉnh sửa Godot để bạn có thể gửi mô hình từ ứng dụng web Meshy thẳng vào các scene Godot của mình.


Trước khi bắt đầu

  • Tải plugin, một tệp .zip, từ trang tích hợp Meshy for Godot.

  • Bạn cần có tài khoản Meshy. Để gửi mô hình bằng Bridge, bạn cần gói Pro trở lên.

Cài đặt plugin

Để cài đặt plugin, hãy làm theo các bước sau:

  1. Giải nén tệp bạn đã tải xuống. Tệp này chứa một thư mục meshy-godot-plugin.

  2. Nếu dự án của bạn chưa có thư mục addons, trong bảng điều khiển FileSystem của Godot, nhấp chuột phải vào res://, sau đó nhấp Create New > Folder.

    Bảng điều khiển FileSystem của Godot với menu ngữ cảnh res:// đang mở và Create New, Folder được tô sáng

  3. Nhập addons làm tên thư mục.

  4. Nhấp OK.

    Hộp thoại Create Folder của Godot với addons được nhập làm tên và nút OK

    Bảng điều khiển FileSystem của Godot hiển thị thư mục addons mới dưới res://
  5. Kéo thư mục meshy-godot-plugin vào thư mục addons trong bảng điều khiển FileSystem. Giữ nguyên tên thư mục, vì plugin sẽ tải các tệp của nó từ res://addons/meshy-godot-plugin.

    Bảng điều khiển FileSystem của Godot với thư mục meshy-godot-plugin và các tệp của nó bên trong addons

  6. Trên thanh menu của Godot, nhấp Project > Project Settings, sau đó nhấp vào tab Plugins.

  7. Chọn hộp kiểm Enabled cho Meshy official plugin.

    Project Settings của Godot ở tab Plugins với Meshy official plugin được liệt kê và bật

Khi plugin được bật, một tab Meshy sẽ xuất hiện ở đầu trình chỉnh sửa, bên cạnh AssetLib. Tab này mở bảng mà bạn dùng để nhận mô hình.

Các tab 2D, 3D, Script, Game, AssetLib của trình chỉnh sửa Godot, và tab Meshy do plugin thêm vào

Bước tiếp theo

  • Để gửi mô hình đầu tiên của bạn từ Meshy sang Godot, xem Bridge to Godot.

  • Để nhập một nhân vật đã gắn rig cùng với hoạt hình của nó, xem Animated models.