Meshy for Godot

Meshy web uygulamasından modelleri doğrudan Godot sahnelerinize gönderebilmek için Meshy eklentisini Godot düzenleyicisine yükleyin.


Başlamadan önce

  • Eklentiyi, bir .zip dosyası olarak, Meshy for Godot entegrasyon sayfasından indirin.

  • Bir Meshy hesabınız olması gerekir. Modelleri bridge ile göndermek için Pro plan veya daha üst bir plana ihtiyacınız vardır.

Eklentiyi yükleyin

Eklentiyi yüklemek için şu adımları izleyin:

  1. İndirdiğiniz dosyanın zip'ini açın. İçinde bir meshy-godot-plugin klasörü bulunur.

  2. Projenizde addons klasörü yoksa, Godot FileSystem panelinde res:// üzerine sağ tıklayın ve ardından Create New > Folder öğesine tıklayın.

    res:// bağlam menüsü açık ve Create New, Folder vurgulanmış Godot FileSystem paneli

  3. Klasör adı olarak addons girin.

  4. OK düğmesine tıklayın.

    Ad olarak addons girilmiş ve OK düğmesi bulunan Godot Create Folder iletişim kutusu

    res:// altında yeni addons klasörünü gösteren Godot FileSystem paneli
  5. meshy-godot-plugin klasörünü FileSystem panelindeki addons klasörünün içine sürükleyin. Eklenti dosyalarını res://addons/meshy-godot-plugin konumundan yüklediği için klasör adını olduğu gibi koruyun.

    addons içinde meshy-godot-plugin klasörü ve içindeki dosyaları gösteren Godot FileSystem paneli

  6. Godot menü çubuğunda Project > Project Settings öğesine tıklayın ve ardından Plugins sekmesine tıklayın.

  7. Meshy official plugin için Enabled onay kutusunu seçin.

    Plugins sekmesinde Meshy official plugin listelenmiş ve etkinleştirilmiş Godot Project Settings

Eklenti etkinleştirildiğinde, düzenleyicinin üst kısmında, AssetLib öğesinin yanında bir Meshy sekmesi görünür. Bu sekme, modelleri almak için kullandığınız paneli açar.

2D, 3D, Script, Game, AssetLib Godot düzenleyici sekmeleri ve eklenti tarafından eklenen Meshy sekmesi

Sonraki adımlar

  • Meshy'den Godot'a ilk modelinizi göndermek için bkz. Bridge to Godot.

  • Rigli bir karakteri animasyonuyla birlikte içe aktarmak için bkz. Animated models.